Skip to content

rootfs.size doesn't work with latest alpine-base:0.2.0 image as it lacks resize2fs #132

Description

@codethief

When I specify rootfs.size for my VM (using the default alpine-base image), Gondolin v0.12.0 fails with:

Command failed, Error: failed to resize rootfs inside guest (exit 127): rootfs.size requires resize2fs in the guest image (install e2fsprogs)
    at VM.ensureRootfsResized (file:///<project dir>/node_modules/@earendil-works/gondolin/dist/src/vm/core.js:1257:19)
    at process.processTicksAndRejections (node:internal/process/task_queues:104:5)
    at async file:///<project dir>/node_modules/@earendil-works/gondolin/dist/src/vm/core.js:887:13
    at async VM.withStartTimeout (file:///<project dir>/node_modules/@earendil-works/gondolin/dist/src/vm/core.js:917:20)
    at async VM.startInternal (file:///<project dir>/node_modules/@earendil-works/gondolin/dist/src/vm/core.js:876:9)
    at async VM.startExec (file:///<project dir>/node_modules/@earendil-works/gondolin/dist/src/vm/core.js:809:13)

It seems the e2fsprogs dependency was added to images/alpine-base.json in commit 4652b55 but the latest alpine-base image release (v0.2.0) was weeks before that (c6efbe3), so didn't include that change.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions